AODA – new website requirements for 2021

Digital Accessibility – Include everyone

Was your website built to be AODA* compliant?

Many of the sites we’ve built in the last few years have been built to be compliant, however as of Jan 1 the requirements are changing. Whereas previously sites had to meet specifications as defined by WCAG 2.0 Level A, as of Jan 1st they need to meet WCAG 2.0 Level AA**
The upgraded guideline includes accessiblity options in areas such as: distinguisahable content, navigable content, readable content, predicatable web pages, and input assistance. You can read all about them at Ontario.ca

To have your website checked to see if it complies with the level AA requirements, reply to this email and email us to have an audit run for you.

Need to make your site compliant?

We’ve been working with a company called Accessibe who provides an automated, AI solution that automatically keeps your website compliant.

As you may know, AODA compliance needs to be maintained by website editors. Any change to your website – new text or images for example – can impact the compliance if its not entered correctly.

The Accessibe solution also:

  • automatically keeps your website compliant.
  • provides monthly reports with verification status.
  • adds a small widget to the website through which a visitor can modify settings if they need – make text bigger, highlight links, etc., which is one of the AODA requirements.

We’ve currently got Accessibe installed on seethroughweb.com (looks like a little blue person on to right botton corner) so you can see what it looks like in action.

The Accessibe service is $490 USD/year and automatically keeps your site compliant, no matter who is updating or changing it.
Who must comply?

By law, you must make new and significantly refreshed public websites accessible if you are:

  • a private or non-profit organization with 50+ employees; or
  • a public sector organization

The organization that controls the website must meet the accessibility requirements.

Compliance deadline

Beginning January 1, 2014: new public websites, significantly refreshed websites and any web content posted after January 1, 2012 must meet Web Content Accessibility Guidelines (WCAG) 2.0 Level A
Beginning January 1, 2021: all public websites and web content posted after January 1, 2012 must meet WCAG 2.0 Level AA other than criteria 1.2.4 (live captions) and 1.2.5 (pre-recorded audio descriptions)

* Accessibility for Ontarians with Disabilities Act, 2005
** Web Content Accessibility Guidelines (WCAG)

Looking for excellent Wordpress hosting?  Check out Kinsta. Easy to use, fast, and secure.

Looking for excellent Wordpress hosting? Check out Kinsta. Easy to use, fast, and secure.

2. Use a security plugin

Wordpress security plugins can do a lot to protect your site: from blocking multiple attempts to break into your website to scanning for modified files and folders. Most are free, some have a relatively inexpensive paid Pro option which can be worth it for greater peace of mind.

We use Wordfence on most sites ourselves, but there are other great security plugins out there like Sucuri and iThemes Security Pro.